Actualiza Java para solucionar vulnerabilidad de seguridad

Ya contamos con una actualización crítica en este PPA, el cual originalmente iba a ser lanzada a mediados de febrero pero fue adelantado debido a lo importante que resultaba el solucionar esta falla. Pasen a ver

El 1 de enero de 2013 Java 7 activó una falla de seguridad crítica que permite a personas no deseadas activar código malicioso en nuestros equipos. Oracle publicó un parche de seguridad que corrige parcialmente la falla pero no la elimina. La solución primaria es desinstalar pero si no quieres hacerlo puedes actualizar el parche.

Si te interesa abre la terminal e instala con

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer

El instalador hará el resto.

Más información de lo ocurrido acá. Gracias a webupd8 por el dato

Apple V/S Linux (Parte VII): solución al problema de conexión con Ubuntu y IOS5

Hace unos días atrás y debido a un problema con el iphone me vi obligado a manipular el equipo y borrar todo. Quise aprovechar lo ocurrido y lo actualicé a la versión 5 IOS (que, dicho sea de paso, funciona muy bien pero gasta como enfermo la batería).
El problema surgió cuando quise conectarlo a Ubuntu, ya que me mostró este error:

Iba a empezar a correr en círculos, pero no me desesperé. Ingresé a launchpad y busqué el problema. Afortunadamente existía un tópico dedicado a este error, junto con la solución correspondiente. El responsable de la solución se llama john Birne y es más fácil de lo que parece.

Sigue leyendo

HowTo: Instalar OpenAtrium en Dreamhost

OpenAtrium como indica en su página web es un sistema parte intranet, parte proyecto do-it-yourself, todo open source. Está basado en el archiconocido Drupal, de hecho, la instalación es exactamente igual excepto por un punto al comienzo donde hay que elegir el perfil OpenAtrium. No voy a detener a explicar como instalar Drupal, porque ya existen sitios lo suficientemente completos y repertirlo no sería más que una inútil forma de duplicar información. Así que les dejaré eso a ustedes.

Sobre OpenAtrium les puedo decir que es un sistema sumamente fácil de utilizar que cuenta con varias funcionalidades como wiki, calendario, shoutbox (una especie de twitter), blog, lista de tareas, documentos y sistema de tickets. Todo esto además, puede configurarse en base a distintos grupos independientes entre sí y asignando distintos roles a cada usuario. Como si fuera poco, la plataforma es estéticamente agradable e insisto, muy fácil de utilizar.

La verdad es que es una herramienta genial para administrar comunidades o cualquier otra asociación donde necesitemos coordinar gente y no encontrábamos la forma de hacerlo.

¿Problemas para instalarlo en DreamHost? Click aquí!

Solución error llaves públicas GPG de Launchpad en Ubuntu (actualizado)

Amigos míos, actualizo este post con la nueva solución disponible para usuarios de Karmic Koala :)

Si hoy te levantaste en la mañana, quisiste actualizar tu Ubuntu y te apareció el siguiente error:

Error de GPG: http://ppa.launchpad.net intrepid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 6AF0E1940624A220

Eres uno más de los muchos usuarios que han sufrido con este problema. ¿La razón?. Los repositorios PPA de Launchpad (PPA = Personal Package Archives), que son repositorios de Ubuntu donde puedes guardar tus proyectos personales y en donde están muchos proyectos de programas, han empezado a ofrecer paquetes firmados.

Para esto tenemos 2 soluciones: la primera es dirigirte a la página donde se encuentra el proyecto que te arroja el error de la llave GPG y descargar su clave y desde Origenes de Software (Pestaña Autentificación) pegar esa clave.

No parece muy difícil, ¿no?

El problema surge cuando tienes muchas claves que descargar. Eso puede hacer que pierdas la paciencia con mucha facilidad.

Por eso la segunda solución es mucho más sencilla. En Ubuntuforums crearon un script que automáticamente busca en nuestros repositorios aquellos conflictivos y descarga la clave correspondiente.

Los pasos son los siguientes:

  • Descarga el script de aquí y descomprímelo
  • Abres la terminal (Aplicaciones/Accesorios/Terminal) y te diriges a la carpeta donde se encuentra el script. En mi caso lo que tuve que escribir es cd Documentos
  • Ejecutas el script según la versión que tengas: sudo ./launchpad-update intrepid (si tienes Intrepid. Lo cambias por Hardy o Jaunty, si usas alguna de esas versiones)
  • Esperas, ¡y listo!

Nueva solución

Ulyses2k subió una nueva solución. Ésta es mucho más sencilla, ya que lo único que tienes que hacer es descargar, descomprimir, dirigirte con la terminal hacia donde está el archivo descomprimido y escribe sudo ./launchpad-update. Automáticamente reconocerá la versión que estamos usando y descargará las llaves. Para ésto, dirígete a éste post y descarga el archivo adjunto (debes estar registrado para poder descargar el archivo)

Solución para Karmic Koala

En Karmik Koala la solución es mucho más sencilla. Sólo tienes que descubrir a qué programa pertenece la llave gpg no descargada. Luego abres una terminal y escribe lo siguiente:

sudo add-apt-repository ppa: nombre del repositorio en Launchpad

Esto permitirá la descarga tanto de la llave gpg como del repositorio completo, sin necesidad de agregarlo al sources.list.

Por ejemplo, para añadir la llave gpg y el repositorio de AWN escribo sudo add-apt-repository ppa:awn-testing

Actualizas con sudo apt-get update, ¡y listo!

Espero que les sirva.  Agradecimientos a Desde Ubuntu para el Mundo y Ubuntulife por su ayuda

Ahora he encontrado una nueva solución. La puedes conocer siguiendo éste enlace

Solucionar el problema con libpng y StepMania en Ubuntu Intrepid

)
Foto cortesía de Wikipedia :)

StepMania es un juego de simulación inspirado en el legendario y no siempre bien ponderado Dance Dance Revolution (juego que por cierto, marco mi adolescencia). Hace un par de días que quería instalarlo para tener algo con lo que entretenerme cuando esté en el sur.

Intenté con el paquete de GetDeb, pero la verdad es que no hubo caso hacerlo correr (era para Hardy), así que opté por el camino más “complicado” que es el de descargarlo directamente desde la web oficial.

Voy a ejecutarlo desde una terminal y me encuentro con un bello error:

La solución luego del salto…