Solucion error llaves públicas GPG de Launchpad en Ubuntu (actualizado)

Si hoy te levantaste en la mañana, quisiste actualizar tu Ubuntu y te apareció el siguiente error:

Error de GPG: http://ppa.launchpad.net intrepid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 6AF0E1940624A220

Eres uno más de los muchos usuarios que han sufrido con este problema. ¿La razón?. Los repositorios PPA de Launchpad (PPA = Personal Package Archives), que son repositorios de Ubuntu donde puedes guardar tus proyectos personales y en donde están muchos proyectos de programas, han empezado a ofrecer paquetes firmados.

Para esto tenemos 2 soluciones: la primera es dirigirte a la página donde se encuentra el proyecto que te arroja el error de la llave GPG y descargar su clave y desde Origenes de Software (Pestaña Autentificación) pegar esa clave.

No parece muy difícil, ¿no?

El problema surge cuando tienes muchas claves que descargar. Eso puede hacer que pierdas la paciencia con mucha facilidad.

Por eso la segunda solución es mucho más sencilla. En Ubuntuforums crearon un script que automáticamente busca en nuestros repositorios aquellos conflictivos y descarga la clave correspondiente.

Los pasos son los siguientes:

  • Descarga el script de aquí y descomprímelo
  • Abres la terminal (Aplicaciones/Accesorios/Terminal) y te diriges a la carpeta donde se encuentra el script. En mi caso lo que tuve que escribir es cd Documentos
  • Ejecutas el script según la versión que tengas: sudo ./launchpad-update intrepid (si tienes Intrepid. Lo cambias por Hardy o Jaunty, si usas alguna de esas versiones)
  • Esperas, ¡y listo!

Nueva solución

Ulyses2k subió una nueva solución. Ésta es mucho más sencilla, ya que lo único que tienes que hacer es descargar, descomprimir, dirigirte con la terminal hacia donde está el archivo descomprimido y escribe sudo ./launchpad-update. Automáticamente reconocerá la versión que estamos usando y descargará las llaves. Para ésto, dirígete a éste post y descarga el archivo adjunto (debes estar registrado para poder descargar el archivo)

Espero que les sirva.  Agradecimientos a Desde Ubuntu para el Mundo y Ubuntulife por su ayuda

Ahora he encontrado una nueva solución. La puedes conocer siguiendo éste enlace

39 comentarios en “Solucion error llaves públicas GPG de Launchpad en Ubuntu (actualizado)

  1. hola amigos, espero que no les caiga mal pero no e podido encontrar una solucion a un problema que tengo con ubuntu 8.10 espero que me pueda ayudar :

    el icono de los dispositivos de red (miniaplicacion networkmanager 0.7.0 me dice lo siguiente : dispositivo no esta gestionado (esto para eth0 cable eth1 inalambrica.
    aunque tengo conexion internet.
    que significa esto .
    e buscado informacion pero no e podido encontrar una solucion optima.

    espero me puedas ayudar.

    atte.
    manuel salas.

    Me gusta

    • yo tambien tengo el mismo problema, y lo curioso es que hay conexion por red. inicialmente cuando lo instale, me detectaba las redes, pero despues de darle pppoeconf se pierde la conexion inalambrica, y no me reconoce ninguna de las tres que hay. Estoy en busca de la solucion también

      Me gusta

  2. ayudaaa por fis!!!
    vi el post y dije “oh mi diosh justo lo que me pasa a mi” y fui feliz, el unico problema es que me meti donde sale descargar “aqui” y no me deja :(
    que puedo hacer?
    soy nueva en esto! lo siento=(

    Me gusta

  3. @manuel salas: no hay problema. No es enojarse, pero si no explicas en detalle el problema no te podemos ayudar. Te recomiendo que ingreses en foros, que son lo más adecuado para estas situaciones. Además, siempre es útil conocer tu equipo: capacidad, tipo de tarjeta, etc. Porque así no me parece nada…
    @jesy: ????? No tengo idea de lo que estás hablando. ¿Podrías ser más específica?

    Me gusta

  4. jeje que vola, entonces mi equipo es:
    un laptop Dell Inspiron 1525
    Intel Core 2 Duo 1.66GHz
    2.5Gb Ram
    SO 32 Bit
    Les explico todo mi problema, me salió el error exacto que sale arriba, en el blog, entonces clickié ahí pero me salía que no podía, por lo que decidí hacerme un usuario, pero aún así no me deja descargarlo, dice que no tengo permiso del administrador
    Por otro lado, quise actualizar eso pensando que podría ayudarme con mi otro problema, que es el que efectivamente me complica:
    Cuando estoy en Ubuntu 8.10 y estoy navegando por internet con Firefox y ademas tengo el amsn prendido y me habla alguien (cuando no tengo ninguna conversacion abierta) se queda pegado el pc y no responde NADA trato de irme al modo consola y no puedo,ni si quiera aparece el mouse :S asi que no me queda otra opcion que apagarlo a la mala y volverlo a prender, creí que era un problema de amsn pq antes simplemente este que quedaba pegado y forzaba el cierre y listo (por eso lo formatié y ahora me da este otro problema); la cosa es que trate de usar emesene y pasa lo mismo
    que puede ser :S? (lo formatie dos veces!!)

    Me gusta

  5. Mira, Abre firefox; desde la terminal escribe amsn. Cuando se pegue escribe el error que aparece en la terminal. No se me ocurre que puede pasar, pero por lo menos hagamos el intento :-)

    Me gusta

  6. que rapido para contestar =O gracias
    el problema es que trate de hacerlo pero ni eso puedo
    se detiene completamente no me deja hacer nada de nada
    ni mover el mouse
    ni responde a ninguna tecla ni comando, solo al boton de apagar y cuando lo mantengo
    es decir cuando lo obligo a apagarse :S

    Me gusta

    • Lo siento, encontre otro lugar donde descargar el script y al parecer es el mismo
      y ahora me sale otro problema:
      tanchi@Tanchi-laptop:~/Escritorio$ sudo ./launchpad-update intrepid
      Release: intrepid
      Please Wait…
      cat: keyss: No existe el fichero ó directorio
      rm: no se puede borrar «keyss»: No existe el fichero ó directorio

      que hago ahora =( ??
      por favor ayudame, lo siento por inchar tanto XD

      Me gusta

  7. @tanchita: pero si te dije como descargar el script. Con respecto al problema ¿te diriges con la terminal al lugar donde se encuentra el script? Si no, fíjate que tenga permisos de ejecución. Para eso, haz click con el botón derecho en el script, haz click en propiedades y ve la pestaña permisos; asegúrate que esté marcada la opción Permitir ejecutarse como programa

    Me gusta

    • bueno creo que lo hice bien, al menos no me lanzo ningun error pero me sigue saliendo el error de la llave, soy un fiasco… sera un problema entre el pc y la silla??

      Me gusta

  8. cuando apreto “aqui” y me sale descargar launchpad-update-final.zip lo clickeo y me aparece esto:
    “tanchita, you do not have permission to access this page. This could be due to one of several reasons:
    Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else’s post, access administrative features or some other privileged system?
    If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.”

    por eso busque en otro lugar y aparecio un script que dice launchpad-update asumi que era el mismo pero me sigue saliendo el error:
    “Error de GPG: http://ppa.launchpad.net intrepid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 6AF0E1940624A220″

    Me gusta

  9. @tanchita: no desesperes.
    Lo del script es raro, porque yo no tengo problemas. ¿Tienes una cuenta de usuario en ubuntuforums? Porque si no, regístrate. Ahí podrás verlo. Después descárgalo.
    Ese script no es el que uso en este post. El que yo estoy usando se llama launchpad-update-final.
    Con eso tu problema se solucionaría

    Me gusta

    • e llama launchpad-update-final.sipo si tengo la cuenta, por eso puse el mensaje textual a como salia, me dice “tanchita” es decir reconoce mi usuario pero hasta ahi llego =(

      Me gusta

    • Bueno, no encontre otro lugar, porque me enviaban todos a Ubuntuforums no se porque no puedo dice que no tengo los permisos, pero al parecer todos pueden :S
      en fin
      encontre esta otra forma en un post
      al parecer pude actualizar bien
      En la terminal escribe:

      1º. PUBKEY=5E6F7G8H (#es decir, los últimos 8 caracteres de la clave de error).
      2º. gpg –keyserver subkeys.pgp.net –recv-key $PUBKEY
      3º. gpg -a –export $PUBKEY | sudo apt-key add –
      4º. sudo aptitude update

      Me gusta

  10. @tanchita: para la próxima vez, lee mejor el post que subí. Si te fijas, la solución que me dices es la misma que publiqué al principio. Sólo debes copiar todos los números que salen después de PUBKEY y los pegas…

    Me gusta

    • me tinco que era lo mismo que tu primera opcion, solo que no sabia como hacerlo y ahi se especificaba, pero de todos modos muchas gracias por tratar de ayudarme! aunque no me ayudo con el problema de que se queda pegado, a lo mejor solo es un problema de compatibilidad y tengo que esperar hasta que salgan nuevas actualizaciones, mientras tanto ocupo Opera, al parecer no se genera el mismo problema
      GRACIAS!

      Me gusta

  11. Pablo N. muchas gracias, problema resuelto.

    Pero ahora me sale esto es synaptic:

    Imposible obtener http://www.getautomatix.com/apt/dists/edgy/main/binary-i386/Packages.gz 404 Not Found
    Imposible obtener http://www.getautomatix.com/apt/dists/dapper/main/binary-i386/Packages.gz 404 Not Found
    Algunos archivos de índice no se han podido descargar, se han ignorado,
    o se ha utilizado unos antiguos en su lugar.

    Tratando de instalar Automatix2 desde ahi.

    Si sabes de una solucion a esto, agradecer no bastaria.

    Me gusta

  12. Hola muy buenas Pablo, acabo de actualizar a la version 9.04 jaunty de ubuntu, nada que me arroja la terminal el siguiente error:

    Release: jaunty
    Please Wait…
    cat: keyss: No existe el fichero ó directorio
    rm: no se puede borrar «keyss»: No existe el fichero ó directorio

    me lo hacia antes tambien con el ubuntu 8.04 Intrepid como si no encontrara el archivo de la llave. e mirado lo que comentas de los permisos para ejecutar y esta bien.

    pero nada no puedo.

    gracias.

    Me gusta

  13. la neta ami me gusta mas este metodo
    solo cambias las XXXXXXX por Los ultimos 8 dijitos de la publick key que te falta y con eso solucionas :D
    $gpg –keyserver keyserver.ubuntu.com –recv XXXXXXXX
    $gpg –export –armor XXXXXXXX | sudo apt-key add

    Me gusta

  14. que tal buen día

    soy nuevo en esto, ando intentando descargar ciertos programas desde la terminal los cuales son tucan y clipgrab respectivamente pero al querer ejecutarlos me marca un error el cual es el siguiente

    W: Imposible obtener http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu/dists/utopic/main/binary-amd64/Packages 404 Not Found

    W: Imposible obtener http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu/dists/utopic/main/binary-i386/Packages 404 Not Found

    E: Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar

    por lo que buscando en foros encontré que necesito unas llaves las cuales descargue, el problema que cuando me voy desde la terminal y ejecute el archivo me aparece este error gpg: no se han encontrados datos OpenPGP válidos

    mi versión de ubuntu es la 14.10 64 bits.. agradecería su ayuda..

    saludos

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .